Regulated Data Environment - Globus Service is Down – Incident details
System Under Maintenance
Globus Service is Down
Resolved
Partial outage
Started about 1 year agoJune 02, 2025Lasted about 4 hoursJune 02, 20258:58 PMJune 03, 20251:00 AMUTC
Affected
Globus
Operational from 8:58 PM to 1:00 AM
Updates
Resolved
UTC
Resolved
UTC
This incident has been resolved and Globus service has been restored.
Investigating
UTC
Investigating
UTC
The Globus service for the Regulated Data Environment is currently down following a failed patch applied during today's scheduled maintenance. Our technical team is actively working to resolve the issue and restore service as quickly as possible. We will notify you as soon as service has been restored.