Regulated Data Environment - Globus — Temporary Service Interruption – Incident details

System Under Maintenance

Globus — Temporary Service Interruption

Resolved
Major outage
Started 4 months agoLasted about 11 hours

Affected

Globus

Major outage from 4:00 PM to 2:37 AM

Updates
  • Resolved
    UTC
    Resolved

    This incident has been resolved. Globus access has been fully restored and services are operating normally.

  • Identified
    UTC
    Identified

    Our team encountered an issue during a standard key rotation process that has temporarily taken Globus offline. We are actively working to resolve this and expect the service to be restored later tonight or by mid-morning tomorrow at the latest. We apologize for any inconvenience this may cause and appreciate your patience as we work through the issue. We will provide an update once service has been fully restored.